The MacCast » Question of the Day

I’m sure more than a few of us have wanted to change this setting and not always been able to find it.

Hooking up the iphone opens iPhoto every time AGAIN, just like it used to be before people complained to apple until they fixed that. Unbelievable! Do you know a fix?

Stop iphoto launching

Did you get a new phone or rest your device? That setting is set per device and you need to set it using the Image Capture application (Applications–>Image Capture). With the phone connected launch Image Capture. You should see your iPhone listed in the ‘Devices’ at the top of left hand column. At the bottom of that same column you should see the Device Settings pane. If you don’t you may need to click the little ‘Show Device Settings’ icon (looks like a window with a triangle) to display the pane. At the top of that pane you can change the ‘Connecting this iPhone opens:’ setting to ‘No application’. You can also set it to launch an application other than iPhoto, say Image Capture or any other application you’d like by selecting the ‘Other…’ option. Once you have the preference set you can quit Image Capture and it should be set until you get a new device or restore your iPhone.
I should have checked iPhoto ’11 first. Before I get a bunch of email on this… You CAN also set this setting in iPhoto, at least the latest version. In iPhoto go to the iPhoto menu –> Preferences –> General and then adjust the ‘Connecting camera opens:’ setting to ‘No application’.

Adjust setting in iPhoto


Hey Adam,

I’ve got a new Macbook Pro with OS X and Apps on a 128 Gb SSD in the SuperDrive bay. My data lives on a 1 TB HDD. Right now I have Time Machine backing up the 1TB drive (since OS and Apps are easily reinstalled and the SSD is more durable). The problem is that I need to put my MBP on my desk and plus in the Time Machine drive.

Is there a way to hook up the Time Machine to the USB port on my Airport Extreme and have the MBP connect to the shared drive automatically every time it connects to my WiFi and then have Time Machine back up? It would be sweet to just have the MBP backup automatically every time it’s in range of my WiFi.



Unfortunately that isn’t supported,

“Time Machine can’t back up to an external disk connected to an AirPort Extreme”

Apple’s only supported solution in the “Airport” line  is the Time Capsule. I believe you may also connect a disk to another Mac and then use file sharing from System Preferences–>Sharing to make the disk available on the network. From there you would be able to mount the shared disk on your Macbook Pro and use Time Machine back up to it. As noted in the article liked to above, both machines need to be running 10.5.6 or later and must be using Apple File Protocol (AFP) file sharing.

There are ways to hack a solution together, but most report mixed results and it’s not supported by Apple. In my opinion you don’t want to have a backup system that could be less than reliable.

You know I get great questions from you everyday via email. Some of these I respond to on the show, but others I just answer via email. That’s great for the person asking the question, but what about the rest of us?

Welcome to the inaugural post of the “Maccast Question of the Day”. Today I respond to a question about the iPad and why it never quite seems to know exactly what time it is.

Roger asks:

I have noticed recently that the time settings on my iPad do not match with the time settings on my MacBook even though I have syncronized the two reqularly.  Over a week or so the iPad can be off more than 20 minutes.  I know the MacBook will adjust the system time with input from the Internet.  Does the iPad have a similar capability?  If so, where is the setting?

Funny you should mention this. It depends. Do you have a Wi-fi or 3G model? If you have the 3G model, just turn on the cellular data from Settings–>Cellular Data for a minute or so and it will update the time from the cellular network (this works even if you don’t have an active service contract). On the Wi-fi model, you have to adjust it manually. Apple needs to fix this, but until then we’re apparently SOL. The Mac Observer posted an excellent article about the issue and they recommend an App called Emerald Time (iTunes link) that can get an accurate time from an Internet time server. Unfortunately, while the App can give you an accurate time and tell you how far off the iPads internal clock is, it can’t fix the iPad’s clock (due to API restrictions). You’ll still need to make the adjust manually in the iPad’s Date & Time settings. Why the heck Apple can’t just have the iPad connect to the same Apple network time server it uses for the Mac is beyond me. Even if they didn’t do that couldn’t they at least adjust the clock when you sync it to iTunes? Seems like an area of iOS where Apple definitely needs to devote a little more time, eh?